This project has moved and is read-only. For the latest updates, please go here.

Fail: 0x80004005

Feb 1, 2017 at 2:25 PM

i have installed filemeta today. (x86.msi)
i have added a property handler to pdf.
now a place was there for keywords, categories and so on...
i added keywords, categories, ... in Windows Explorer
I have pressed saved
You will see a Windows 10 error message
Error code: 0x80004005
Due to an unknown error, no properties could be added.

please....what have i done wrong?

greetings from Germany
(with little help from Google translator)
Feb 1, 2017 at 3:32 PM

This is usually a question of restarting all instances of Explorer, or at the very worst, rebooting your system. It happens because Explorer caches configuration that it has read from the registry.

If this does not fix your problem, let me know.

Feb 1, 2017 at 4:06 PM
i stopped the windows explorer process in the task manager.
that did not help.
what have i to do in detail ...please tell me step by step.

Feb 1, 2017 at 7:27 PM
The simplest way is to open the File Association Manager, and click the Restart Explorer button.

Feb 1, 2017 at 9:30 PM
i did that several times.
i always get the error Code.

What else can i do?
Feb 2, 2017 at 5:37 PM
There have been cases in the past where a reboot was required. Could you try this please?

Feb 21, 2017 at 3:30 PM
Thanks for what looks like a great tool, exactly what I need. Unfortunately, it is not fully working for me - I am getting the same error message described here whenever I try to set/change a meta data value, on a Windows 7 system.

I have tried restating Windows Explorer, and a full reboot, with no change in the results. I also tried update Registry, however the Association tool says that no changes have been made which require a Registry update.

Any other suggestions?
Mar 5, 2017 at 11:42 AM

It’s looking as though some kind of diagnostic program is going to be needed to identify these problems. I’ll have a look and see what I can do.

Apr 25, 2017 at 1:50 PM
I have now created a diagnostic program to try and figure out what is going on. Property Tester 1.0 is available as a Download. Please try it out and report the results.

May 10, 2017 at 3:56 PM
Hi Dijji

I've added a property handler to PDF using File Meta.
I faced similar problems of Error Code 0x80004005 while trying to enter TAGS for a PDF file in Windows Explorer
I am running Windows 10 and the PDF files which I am trying to add TAGS are located on an external portable SAMSUNG T3 SSD DRIVE.

I read through this thread and I downloaded Property Test 1.0 for diagnostics purpose.

Below are the test results

File: D:\test.pdf

Property Handler: {D06391EE-2FEB-419B-9667-AD160D0849F3}

Error: 0x80040154 instantiating Property Handler

Extension .pdf has no configured property handler

Hope you can advice on how to rectify this issue. I've thousands of readings in PDF which would benefit a lot if I can search the content with TAGS.

Many thanks
May 16, 2017 at 4:30 PM
This error indicates that the property handler cannot be loaded because it or one of its dependencies cannot be found.

The first check is, are you running on a 64-bit system? If not, then you have installed the wrong version of File Meta.

Secondly, C:\Program Files\File Metadata should contain a file FileMetaPropertyHandler.dll, and if you look at the Details tab of the Properties dialog, you should see that the version is 1.5.6 128.0.

Thirdly, the most important dependency is on msvcr100.dll, which you should find in C:\Windows\System32. Despite the name of the directory, this is a 64-bit file. Again, looking at the Details tab of the Properties dialog, you should see that the version is 10.00.40219.325, and that the date modified is 11/06/2011.

Let me know what you find in your system.

Aug 28, 2017 at 11:14 AM
Hi Dijji, I'm having the same issues as soapplex. I have restarted both explorer and the machine, but the problem still persists. My machine is running a 64-bit system, and I'm getting the same test results message from the Property Tester as soapplex. The FileMetaPropertyHandler.dll file is as you described; however, the msvcr100.dll file does not match the version or date modified which you specified, it appears it was not updated as the version states 10.00.40219.1. Any thoughts?
Aug 31, 2017 at 6:06 PM

The error reported by the property tester means “class not registered”, so a check of the registry is in order.

If you run ‘regedit’, then navigate to HKEY_CLASSES_ROOT\CLSID{D06391EE-2FEB-419B-9667-AD160D0849F3}, this should contain a key called InprocServer32, with the default value C:\Program Files\File Metadata\FileMetaPropertyHandler.dll.

If this is missing, then the File Meta property handler is indeed not registered. Please let me know what you find.

If it is missing, one possible cause is failure to load msvcr100.dll. I’m not sure that the difference in the last digits is significant. However, you can download what is definitely the correct version at If you install this, you can then try to fix the File Meta installation by uninstalling and then installing it. This should result in the registry key described above appearing.