This project has moved and is read-only. For the latest updates, please go here.

Not working on Network Drive

Sep 29, 2016 at 6:47 AM

I need this feature to be able to add tags on all PDF files and make it available when searching files. So far everything works great on local files. On network files. It's not working for me.

I am trying to make the tags available on network files but up to now I have no success. This is what I have been doing so far.

Test 1
Add tags on local pdf file.
Copy the file on network drive.
RESULT: file was copied but tags are not.

Add tags on file stored on the network
RESULT: Error code 0x80030002: %1 could not be found

Anyone who have tried this on a network environment?

I have tried this on Win7 and Win10 and the result was the same.

The network drive is a Seagate NAS runing Seagate NAS OS4

Thanks in advance.
Sep 30, 2016 at 10:39 AM
Edited Sep 30, 2016 at 10:40 AM

As a cross check, I repeated your tests with the network drive supplied by a second windows 10 PC. Everything worked as you would expect: copied properties were preserved, and I could remotely add and edit properties.

I also did a little digging on the web, and found this thread:

It’s not a Seagate NAS, but it is a similar problem. The NAS is simply not storing the alternate stream, in this case one containing some Dropbox properties.

Since what File Meta does is store properties in alternate streams (albeit via the support built into NTFS for storing property sets in an alternate stream), if your NAS does not support alternate streams, then there is nothing I can do, any more than I can support a drive formatted with FAT.

I’m sorry, but I really don’t see what I can do to help on this one.

Oct 3, 2016 at 7:53 AM
Does it use different thing than tags of office documents because I can tag office documents without a problem. only files that I enabled with file meta is having problem with adding tags on pdf and txt files.
Oct 3, 2016 at 5:30 PM
Yes, indeed it does. The ins and outs of it all are described on this documentation page:

Office tags work because they are stored “inside the file”, as indeed is the case with all Microsoft-supplied property handlers. But the consequence of this is that Windows, out-of-the-box, cannot write metadata for many extension types, e.g. .txt, and even when it can, can only write a restricted set of properties i.e. those for which the file format allocates storage. Thus, even if Microsoft supplied a property handler for PDF files, which they don’t, it wouldn’t be able to write a Comment, because the PDF format does not define a place to put it.

Oct 12, 2016 at 9:18 AM
Note also the comments of a reviewer of the 1.4 beta, who is having no problems when using a Synology NAS. So I guess support just varies from NAS to NAS, though it doesn't seem to be easy to discover which do and which don't support alternate streams.